re = /(?:[^(|)]*+(\((?:[^()]++|(?1))\))?+)*+\K\|/
str = 'example|example (example(example))|example|example|example(example|example|example(example|example))|example'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result