$re = '/(?:[^(|)]*+(\((?:[^()]++|(?1))\))?+)*+\K\|/';
$str = 'example|example (example(example))|example|example|example(example|example|example(example|example))|example';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;