using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[^(|)]*+(\((?:[^()]++|(?1))\))?+)*+\K\|";
string substitution = @"";
string input = @"example|example (example(example))|example|example|example(example|example|example(example|example))|example";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}