use strict;
my $str = 'example|example (example(example))|example|example|example(example|example|example(example|example))|example';
my $regex = qr/(?:[^(|)]*+(\((?:[^()]++|(?1))\))?+)*+\K\|/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";