#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.+)\s*(?={)|^[\t\s]*(.+;)"
Local $sString = ".grid-container {" & @CRLF & _
" display: grid;" & @CRLF & _
" grid-template-rows: 100px 200px;" & @CRLF & _
"}" & @CRLF & _
"div.target.dunes {" & @CRLF & _
" background-color: green;" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")