import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.+)\\s*(?=\\{)|^[\\t\\s]*(.+;)";
final String string = ".grid-container {\n"
+ " display: grid;\n"
+ " grid-template-rows: 100px 200px;\n"
+ "}\n"
+ "div.target.dunes {\n"
+ " background-color: green;\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}