const regex = /(.+)\s*(?={)|^[\t\s]*(.+;)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.+)\\s*(?={)|^[\\t\\s]*(.+;)', 'gm')
const str = `.grid-container {
display: grid;
grid-template-rows: 100px 200px;
}
div.target.dunes {
background-color: green;
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}