using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.+)\s*(?={)|^[\t\s]*(.+;)";
string input = @".grid-container {
display: grid;
grid-template-rows: 100px 200px;
}
div.target.dunes {
background-color: green;
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}