#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\]\((.+)(?=(\.(svg|gif|png|jpe?g)))"
Local $sString = "# Example header" & @CRLF & _
"**example subheader**" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Some example text in between" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"# Example header" & @CRLF & _
"" & @CRLF & _
"Some more example text." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"But (blabla.png) wil not be transformed"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")