re = /\]\((.+)(?=(\.(svg|gif|png|jpe?g)))/m
str = '# Example header
**example subheader**

Some example text in between

# Example header
Some more example text.

But (blabla.png) wil not be transformed'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end