import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\]\\((.+)(?=(\\.(svg|gif|png|jpe?g)))";
final String string = "# Example header\n"
+ "**example subheader**\n"
+ "\n\n"
+ "Some example text in between\n\n"
+ "\n"
+ "# Example header\n\n"
+ "Some more example text.\n\n"
+ "\n\n\n"
+ "But (blabla.png) wil not be transformed";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}