using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\]\((.+)(?=(\.(svg|gif|png|jpe?g)))";
string input = @"# Example header
**example subheader**

Some example text in between

# Example header
Some more example text.

But (blabla.png) wil not be transformed";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}