#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)\b(border(?:-(?:top|bottom)-(?:left|right))?-radius)\s*:\s([^;]*)(?:;|$)"
Local $sString = "border-radius: 5px;" & @CRLF & _
"Border-Radius: 5px 6px;" & @CRLF & _
"border-top-left-radius: 5px;" & @CRLF & _
"border-top-right-radius: 5px;" & @CRLF & _
"border-bottom-left-radius: 5px;" & @CRLF & _
"border-bottom-right-radius: 5px;" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")