const regex = /\b(border(?:-(?:top|bottom)-(?:left|right))?-radius)\s*:\s([^;]*)(?:;|$)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(border(?:-(?:top|bottom)-(?:left|right))?-radius)\\s*:\\s([^;]*)(?:;|$)', 'gmi')
const str = `border-radius: 5px;
Border-Radius: 5px 6px;
border-top-left-radius: 5px;
border-top-right-radius: 5px;
border-bottom-left-radius: 5px;
border-bottom-right-radius: 5px;
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}