import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(border(?:-(?:top|bottom)-(?:left|right))?-radius)\\s*:\\s([^;]*)(?:;|$)";
final String string = "border-radius: 5px;\n"
+ "Border-Radius: 5px 6px;\n"
+ "border-top-left-radius: 5px;\n"
+ "border-top-right-radius: 5px;\n"
+ "border-bottom-left-radius: 5px;\n"
+ "border-bottom-right-radius: 5px;\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}