re = /\b(border(?:-(?:top|bottom)-(?:left|right))?-radius)\s*:\s([^;]*)(?:;|$)/mi
str = 'border-radius: 5px;
Border-Radius: 5px 6px;
border-top-left-radius: 5px;
border-top-right-radius: 5px;
border-bottom-left-radius: 5px;
border-bottom-right-radius: 5px;
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end