using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"www\.example\.com\/registration\/([^\/]+)";
string input = @"www.example.com/registration/star-mega/x45xx/xxxrfxx/xx";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}