package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`www\.example\.com\/registration\/([^\/]+)`)
var str = `www.example.com/registration/star-mega/x45xx/xxxrfxx/xx`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}