const regex = /www\.example\.com\/registration\/([^\/]+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('www\\.example\\.com\\\/registration\\\/([^\\\/]+)', '')
const str = `www.example.com/registration/star-mega/x45xx/xxxrfxx/xx`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}