// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[\b\f\n\r\t\v\0]+").unwrap();
let string = "A\\\\w
B
C D \\t test
\"This is a text §
inside a text box\"
\\b
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}