import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "http:\\/\\/url.com\\/wp-content\\/uploads\\/\\S+(?<!150x150)\\.(?:jpg|jpeg|png|gif)";
final String string = "http://url.com/wp-content/uploads/2009/09/name-of-the-file-150x150.png\n"
+ "http://url.com/wp-content/uploads/2009/09/name-of-the-file-1324x130.png";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}