re = /http:\/\/url.com\/wp-content\/uploads\/\S+(?<!150x150)\.(?:jpg|jpeg|png|gif)/m
str = 'http://url.com/wp-content/uploads/2009/09/name-of-the-file-150x150.png
http://url.com/wp-content/uploads/2009/09/name-of-the-file-1324x130.png'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end