const regex = /http:\/\/url.com\/wp-content\/uploads\/\S+(?<!150x150)\.(?:jpg|jpeg|png|gif)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('http:\\\/\\\/url.com\\\/wp-content\\\/uploads\\\/\\S+(?<!150x150)\\.(?:jpg|jpeg|png|gif)', 'gm')
const str = `http://url.com/wp-content/uploads/2009/09/name-of-the-file-150x150.png
http://url.com/wp-content/uploads/2009/09/name-of-the-file-1324x130.png`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}