import re
regex = re.compile(r"http:\/\/url.com\/wp-content\/uploads\/\S+(?<!150x150)\.(?:jpg|jpeg|png|gif)", flags=re.MULTILINE)
test_str = ("http://url.com/wp-content/uploads/2009/09/name-of-the-file-150x150.png\n"
"http://url.com/wp-content/uploads/2009/09/name-of-the-file-1324x130.png")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")