# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/abc[^ax]*(?:a(?!bc)[^ax]*|x(?!yz)[^ax]*)*xyz//s;t' <<< "abc 1 abc 2 xyz 3 xyz"