use strict;
my $str = 'abc 1 abc 2 xyz 3 xyz';
my $regex = qr~abc[^ax]*(?:a(?!bc)[^ax]*|x(?!yz)[^ax]*)*xyz~sp;
my $subst = '';
my $result = $str =~ s~$regex~$subst~r;
print "The result of the substitution is' $result\n";