const regex = new RegExp('abc[^ax]*(?:a(?!bc)[^ax]*|x(?!yz)[^ax]*)*xyz', 's')
const str = `abc 1 abc 2 xyz 3 xyz`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);