re = /abc[^ax]*(?:a(?!bc)[^ax]*|x(?!yz)[^ax]*)*xyz/
str = 'abc 1 abc 2 xyz 3 xyz'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result