$re = '~abc[^ax]*(?:a(?!bc)[^ax]*|x(?!yz)[^ax]*)*xyz~s';
$str = 'abc 1 abc 2 xyz 3 xyz';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;