using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([\w.]+\.)\s+.+\sNS\s.+\1";
string input = @"piggyvoucher.com. 86400 IN SOA ns1.krystal.co.uk. admin.krystal.co.uk. (
2014060600 ;Serial Number
86400 ;refresh
7200 ;retry
3600000 ;expire
86400 ;minimum
)
piggyvoucher.com. 86400 IN NS ns1.piggyvoucher.com.
piggyvoucher.com. 86400 IN NS ns2.krystal.co.uk.
piggyvoucher.com. 14400 IN A 77.72.0.110
localhost 14400 IN A 127.0.0.1
mail 14400 IN CNAME piggyvoucher.com.
www 14400 IN CNAME piggyvoucher.com.
ftp 14400 IN A 77.72.0.110
cpanel 14400 IN A 77.72.0.110";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}