import re
regex = re.compile(r"^([\w.]+\.)\s+.+\sNS\s.+\1")
test_str = ("piggyvoucher.com. 86400 IN SOA ns1.krystal.co.uk. admin.krystal.co.uk. (\n"
" 2014060600 ;Serial Number\n"
" 86400 ;refresh\n"
" 7200 ;retry\n"
" 3600000 ;expire\n"
" 86400 ;minimum\n"
" )\n\n"
"piggyvoucher.com. 86400 IN NS ns1.piggyvoucher.com.\n"
"piggyvoucher.com. 86400 IN NS ns2.krystal.co.uk.\n\n\n"
"piggyvoucher.com. 14400 IN A 77.72.0.110\n\n"
"localhost 14400 IN A 127.0.0.1\n\n\n"
"mail 14400 IN CNAME piggyvoucher.com.\n"
"www 14400 IN CNAME piggyvoucher.com.\n"
"ftp 14400 IN A 77.72.0.110\n"
"cpanel 14400 IN A 77.72.0.110")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")