const regex = /^([\w.]+\.)\s+.+\sNS\s.+\1/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([\\w.]+\\.)\\s+.+\\sNS\\s.+\\1', '')
const str = `piggyvoucher.com.	86400	IN	SOA	ns1.krystal.co.uk.	admin.krystal.co.uk.	(
						2014060600 ;Serial Number
						86400 ;refresh
						7200 ;retry
						3600000 ;expire
						86400 ;minimum
	)
piggyvoucher.com.	86400	IN	NS	ns1.piggyvoucher.com.
piggyvoucher.com.	86400	IN	NS	ns2.krystal.co.uk.
piggyvoucher.com.	14400	IN	A	77.72.0.110
localhost	14400	IN	A	127.0.0.1
mail	14400	IN	CNAME	piggyvoucher.com.
www	14400	IN	CNAME	piggyvoucher.com.
ftp	14400	IN	A	77.72.0.110
cpanel	14400	IN	A	77.72.0.110`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
    // The result can be accessed through the `m`-variable.
    m.forEach((match, groupIndex) => {
        console.log(`Found match, group ${groupIndex}: ${match}`);
    });
}