const regex = /^(?:[^\S\r\n]*)(=+)(?:[^\S\r\n]*)(.+?)(?:[^\S\r\n]*=+[^\S\r\n]*)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[^\\S\\r\\n]*)(=+)(?:[^\\S\\r\\n]*)(.+?)(?:[^\\S\\r\\n]*=+[^\\S\\r\\n]*)?$', 'gm')
const str = `== Heading 1 ==
lorem ipsum
=== Sub-Heading 1 ===
lorem ipsum
===Sub-Heading 2 with ugly formatting===
lorem ipsum
=== Sub-Heading 3 without closing equal signs
lorem ipsum
== Heading 2 with ~= in the middle ==
lorem ipsum`;
const subst = `$1 $2 $1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);