// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[^\S\r\n]*)(=+)(?:[^\S\r\n]*)(.+?)(?:[^\S\r\n]*=+[^\S\r\n]*)?$").unwrap();
let string = "== Heading 1 ==
lorem ipsum
=== Sub-Heading 1 ===
lorem ipsum
===Sub-Heading 2 with ugly formatting===
lorem ipsum
=== Sub-Heading 3 without closing equal signs
lorem ipsum
== Heading 2 with ~= in the middle ==
lorem ipsum";
let substitution = "$1 $2 $1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}