# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^,.;!?]\K<\/h[1-6]>/.$0/g;t' <<< "<p>Today, not only we have so many breeds that are trained this and that.</p>
<h4><strong>We must add a dot after the closing strong</strong></h4>
<p>Hunting with your dog is a blah blah with each other.</p>
<h2>No need to change this one!</h2>
<p>Hunting with your dog is a blah blah with each other.</p>"