#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[^,.;!?]\K</h[1-6]>"
Local $sString = "<p>Today, not only we have so many breeds that are trained this and that.</p>" & @CRLF & _
"" & @CRLF & _
"<h4><strong>We must add a dot after the closing strong</strong></h4>" & @CRLF & _
"" & @CRLF & _
"<p>Hunting with your dog is a blah blah with each other.</p>" & @CRLF & _
"" & @CRLF & _
"<h2>No need to change this one!</h2>" & @CRLF & _
"" & @CRLF & _
"<p>Hunting with your dog is a blah blah with each other.</p>"
Local $sSubst = ".$0"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)