using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^,.;!?]\K</h[1-6]>";
string substitution = @".$0";
string input = @"<p>Today, not only we have so many breeds that are trained this and that.</p>
<h4><strong>We must add a dot after the closing strong</strong></h4>
<p>Hunting with your dog is a blah blah with each other.</p>
<h2>No need to change this one!</h2>
<p>Hunting with your dog is a blah blah with each other.</p>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}