import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^,.;!?]\\K</h[1-6]>";
final String string = "<p>Today, not only we have so many breeds that are trained this and that.</p>\n\n"
+ "<h4><strong>We must add a dot after the closing strong</strong></h4>\n\n"
+ "<p>Hunting with your dog is a blah blah with each other.</p>\n\n"
+ "<h2>No need to change this one!</h2>\n\n"
+ "<p>Hunting with your dog is a blah blah with each other.</p>";
final String subst = ".$0";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}