# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[^,.;!?]\K</h[1-6]>"
test_str = ("<p>Today, not only we have so many breeds that are trained this and that.</p>\n\n"
"<h4><strong>We must add a dot after the closing strong</strong></h4>\n\n"
"<p>Hunting with your dog is a blah blah with each other.</p>\n\n"
"<h2>No need to change this one!</h2>\n\n"
"<p>Hunting with your dog is a blah blah with each other.</p>")
subst = ".$0"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.