# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/_(?=.*(?:_|policy))/\n/g;t' <<< "test_0001_suiteid_111_leavepolicy_employee
test_0001_suiteid_111_leavepolicy"