using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"_(?=.*(?:_|policy))";
string substitution = @"\n";
string input = @"test_0001_suiteid_111_leavepolicy_employee
test_0001_suiteid_111_leavepolicy";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}