use strict;
my $str = 'test_0001_suiteid_111_leavepolicy_employee
test_0001_suiteid_111_leavepolicy';
my $regex = qr/_(?=.*(?:_|policy))/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";