import Foundation
let pattern = #"_(?=.*(?:_|policy))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
test_0001_suiteid_111_leavepolicy_employee
test_0001_suiteid_111_leavepolicy
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)