#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:https?:\/\/)?(?:www.|web.|m.)?(?:facebook|fb).com\/(?:video.php\?v=\/?|\?v=\/?|watch\/\?v=\/?|watch\/\?v=\/?)|\S+\/videos\/?"
Local $sString = "https://www.facebook.com/video.php?v=210218373654245" & @CRLF & _
"https://www.facebook.com/watch/?v=2601882823434382" & @CRLF & _
"https://www.facebook.com/cestmeilleurquandcestbon/videos/210218373654245" & @CRLF & _
"https://www.facebook.com/46etplus/videos/210218373654245" & @CRLF & _
"https://www.facebook.com/cestmeilleurquandcestbon/videos/210218373654245" & @CRLF & _
"https://m.facebook.com/watch/?v=210218373654245" & @CRLF & _
"https://web.facebook.com/watch/?v=210218373654245" & @CRLF & _
"http://www.facebook.com/cestmeilleurquandcestbon/videos/210218373654245" & @CRLF & _
"https://facebook.com/cestmeilleurquandcestbon/videos/210218373654245" & @CRLF & _
"https://www.facebook.com/Wickedgirlsblog/videos/210218373654245/" & @CRLF & _
"https://www.facebook.com/watch/live/?v=210218373654245" & @CRLF & _
"https://www.facebook.com/watch/?v=210218373654245" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")