using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:https?:\/\/)?(?:www.|web.|m.)?(?:facebook|fb).com\/(?:video.php\?v=\/?|\?v=\/?|watch\/\?v=\/?|watch\/\?v=\/?)|\S+\/videos\/?";
string input = @"https://www.facebook.com/video.php?v=210218373654245
https://www.facebook.com/watch/?v=2601882823434382
https://www.facebook.com/cestmeilleurquandcestbon/videos/210218373654245
https://www.facebook.com/46etplus/videos/210218373654245
https://www.facebook.com/cestmeilleurquandcestbon/videos/210218373654245
https://m.facebook.com/watch/?v=210218373654245
https://web.facebook.com/watch/?v=210218373654245
http://www.facebook.com/cestmeilleurquandcestbon/videos/210218373654245
https://facebook.com/cestmeilleurquandcestbon/videos/210218373654245
https://www.facebook.com/Wickedgirlsblog/videos/210218373654245/
https://www.facebook.com/watch/live/?v=210218373654245
https://www.facebook.com/watch/?v=210218373654245
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}