// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:https?:\/\/)?(?:www.|web.|m.)?(?:facebook|fb).com\/(?:video.php\?v=\/?|\?v=\/?|watch\/\?v=\/?|watch\/\?v=\/?)|\S+\/videos\/?").unwrap();
let string = "https://www.facebook.com/video.php?v=210218373654245
https://www.facebook.com/watch/?v=2601882823434382
https://www.facebook.com/cestmeilleurquandcestbon/videos/210218373654245
https://www.facebook.com/46etplus/videos/210218373654245
https://www.facebook.com/cestmeilleurquandcestbon/videos/210218373654245
https://m.facebook.com/watch/?v=210218373654245
https://web.facebook.com/watch/?v=210218373654245
http://www.facebook.com/cestmeilleurquandcestbon/videos/210218373654245
https://facebook.com/cestmeilleurquandcestbon/videos/210218373654245
https://www.facebook.com/Wickedgirlsblog/videos/210218373654245/
https://www.facebook.com/watch/live/?v=210218373654245
https://www.facebook.com/watch/?v=210218373654245
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}