import re
regex = re.compile(r"(?:https?:\/\/)?(?:www.|web.|m.)?(?:facebook|fb).com\/(?:video.php\?v=\/?|\?v=\/?|watch\/\?v=\/?|watch\/\?v=\/?)|\S+\/videos\/?", flags=re.MULTILINE)
test_str = ("https://www.facebook.com/video.php?v=210218373654245\n"
"https://www.facebook.com/watch/?v=2601882823434382\n"
"https://www.facebook.com/cestmeilleurquandcestbon/videos/210218373654245\n"
"https://www.facebook.com/46etplus/videos/210218373654245\n"
"https://www.facebook.com/cestmeilleurquandcestbon/videos/210218373654245\n"
"https://m.facebook.com/watch/?v=210218373654245\n"
"https://web.facebook.com/watch/?v=210218373654245\n"
"http://www.facebook.com/cestmeilleurquandcestbon/videos/210218373654245\n"
"https://facebook.com/cestmeilleurquandcestbon/videos/210218373654245\n"
"https://www.facebook.com/Wickedgirlsblog/videos/210218373654245/\n"
"https://www.facebook.com/watch/live/?v=210218373654245\n"
"https://www.facebook.com/watch/?v=210218373654245\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")