# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(_\w+)\1+/$1/gm;t' <<< "proba_m4050_434_3g3_3g3.png
proba_m313_313.png
proba_m5214_2520_gb54_gb54.png
proba_m5214_2520_gb54_gb54_gb54.png
proba_m141_18d5_fd071_fd071.png
proba_m312_534_430_39g.png
proba_m3501_5721.png"