using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(_\w+)\1+";
string substitution = @"$1";
string input = @"proba_m4050_434_3g3_3g3.png
proba_m313_313.png
proba_m5214_2520_gb54_gb54.png
proba_m5214_2520_gb54_gb54_gb54.png
proba_m141_18d5_fd071_fd071.png
proba_m312_534_430_39g.png
proba_m3501_5721.png";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}