import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(_\\w+)\\1+";
final String string = "proba_m4050_434_3g3_3g3.png\n"
+ "proba_m313_313.png\n"
+ "proba_m5214_2520_gb54_gb54.png\n"
+ "proba_m5214_2520_gb54_gb54_gb54.png\n"
+ "proba_m141_18d5_fd071_fd071.png\n"
+ "proba_m312_534_430_39g.png\n"
+ "proba_m3501_5721.png";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}